Loading




Enviar respuesta 
 
Calificación:
  • 0 votos - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[split] Problemas con Hamachi (solucionado)
 
15-06-2009, 06:51 PM
Mensaje: #1
[split] Problemas con Hamachi (solucionado)
dragonauta escribió:Divido el tema para clarificar.
Tema original: Conectarse remotamente a un equipo sin tener IP publica

Hola abejo disculpa estaba funcionando todo bien, reincie el equipo Linux y ahora ya no me puedo conectar en mi hamanchi Windows aparece conectado con la estrellita verde, en mi linux al hacer hamanchi list me sale que estoy conectado a la red pero desde ninguna de las maquinas puedo hacer un ping que crees que pueda pasar???.

Ya he revisado todo y no encuentro el error
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 06:58 PM
Mensaje: #2
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
¿Si haces un ifconfig -a ves alguna interfaz ham0 o tun0?

probablemente haga falta correr tuncfg nuevamente como root

Reglas del Foro | : ? : | Doragonraidā
Visita su sitio web Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 07:06 PM
Mensaje: #3
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
Hola gracias por responder al ejecutar el comando que mencionas sale

[root@localhost tuncfg]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0DW0Ab6B
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:87ff:fe0a:986b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3616 errors:0 dropped:0 overruns:0 frame:0
TX packets:2550 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1711402 (1.6 MiB) TX bytes:259371 (253.2 KiB)
Interrupt:201 Base address:0x6000

ham0 Link encap:Ethernet HWaddr EA:C9:7FEF1-grin7
inet addr:5.130.45.159 Bcast:5.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1200 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:148 (148.0 b) TX bytes:90 (90.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3528 errors:0 dropped:0 overruns:0 frame:0
TX packets:3528 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5601060 (5.3 MiB) TX bytes:5601060 (5.3 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

virbr0 Link encap:Ethernet HWaddr 00�00�00:00
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
inet6 addr: fe80:Èff:fe00:0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:7675 (7.4 KiB)

Ejecuto nuevamente sbin/tuncfg y me sale el mensaje

tuncfg:already running
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 07:25 PM
Mensaje: #4
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
que tal probar la desconexión y reconexión?

$ hamachi go-offline nombre-de-tu-red
$ hamachi logout
$ hamachi stop
$ hamachi start
$ hamachi login
$ hamachi go-online

Reglas del Foro | : ? : | Doragonraidā
Visita su sitio web Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 07:35 PM
Mensaje: #5
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
Gracias por responder he hecho todo loq ue mencionas cree una red incluso volvi hacer paso a paso la instalacion nuevamente y aun no funciona de pronto podrias decirme como hago para desistalar todo y volver a configurar nuevamente porque ya he hecho de todo pero no se que esta pasando lo raro esque se conecta sale conectado pero no hace ping sale tiempo de espera agotado.
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 07:48 PM
Mensaje: #6
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
En linux borra:
/usr/bin/hamachi
/usr/bin/hamachi-init
/sbin/tuncfg
y la carpeta ~/.hamachi

En Windows:
1. desintalar el hamachi
2. Ir a Inicio > Ejecutar > escribir %APPDATA%
3. Borrar la carpeta Hamachi
4. Luego ir a C:\Archivos de programa.. y borrar la carpeta Hamachi

Reglas del Foro | : ? : | Doragonraidā
Visita su sitio web Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 07:58 PM
Mensaje: #7
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
Muchas gracias en Windows si se pero en linux era el problema voy a configurar nuevamente todo a ver como me va esperemos que me funcione sino vuelvo a postear a ver que pasa gracias por toda la ayuda
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
15-06-2009, 11:42 PM
Mensaje: #8
RE: Conectarse remotamente a un equipo sin tener IP publica (solucionado)
Hola amigos les comento que la final termine instalando nuevamente mi centos jeje que cosas de eso se aprende a pesar que desinstale de linux todo seguia sin funcionar no se que hice peor al fin de cuentas me esta funcionando bien ahora tengo este problema

En mi red local me conecto con Hamanchi funciona de maravilla, en este momento estoy en mi casa tengo mi Hamanchi funcionando y me aparece mi equipo Linux que esta en mi oficina hace ping y todo hasta aqui sin problemas.

Ahora trato de conectarme a este equipo abro mi VNC de mi maquina windows pongo la IP que me genera el Hamachi, me sale la ventana para poner la clave se queda un momento pensando y en el panel de mi hamanchi la estrellita sale un destillo circular como que esta tratando de acceder pero al fin de cuentas no se ve nada y no hace nada.

Alguien podria decirme a que se puede deber esto, en mi maquina linux desabilite el firewall por si las moscas, peor no me puedo conectar a pesar de que me hace ping y todo Sad
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
16-06-2009, 09:45 PM
Mensaje: #9
RE: [?][split] Problemas con Hamachi
Hola, recien veo el post, tenes activo el escritorio compartido en Linux?
Visita su sitio web Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
 
16-06-2009, 11:55 PM
Mensaje: #10
RE: [?][split] Problemas con Hamachi
Hola gracias por responder al final logre por fin conectarme remotamente el problema que tenia era que en mi maquina Linux habia desactivado la opcion que dice preguntar antes de entrar o algo asi es decir que el linux preguntaba siempre para poder dejar entrar desactive eso y ahora si de la vida me funciona gracias a todos por la ayuda .

Ahora no se si me pueden hehcar una mano ya que he tratado de configurar hamachi para que se inicie automaticamente al grupo se loguee etc etc cuando la maquina linux se reinicia o se apaga por algun motivo lo que he hecho es lo siguiente a ver si me puede ayudar

1.- sudo vi /etc/rc.local
aqui copio este codigo
/sbin/tuncfg
su - user -c "hamachi start"

2.- hamachi-init -c /etc/hamachi

3.-copio este codigo
#!/bin/bash
case "$1" in
start)
hamachi-init
hamachi start
hamachi login
hamachi join NUESTRA_RED password
hamachi go-online NUESTRA_RED
hamachi set-nick Nuestro_Nick
#hamachi list
;;
stop)
hamachi logout
hamachi stop
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;
esac

4.- /etc/hamachi/init.d# update-rc.d hamachi defaults

Hasta aqui no me da errores ni nada reinicio el equipo y no funciona incluso se desabilita la red es decir mi tarjeta eth0 se desabilita y no se porque ojala me puedan ayudar y con esto creo que quedaria ya todo listo.
Encuentra todos sus mensajes
Cita este mensaje en tu respuesta
Enviar respuesta 


Posibles temas similares...
Tema: Autor Respuestas: Vistas: Último mensaje
Rolleyes Problemas como maquinas windows piro 0 829 06-03-2012 05:33 PM
Último mensaje: piro
  PROBLEMAS DE DNS EN CENTOS COMO ROUTER petrucheli 2 1.885 15-09-2011 09:05 AM
Último mensaje: eng
Question Problemas con squid3 y usuarios msn desde windows (solucionado) eng 1 2.467 15-09-2011 09:01 AM
Último mensaje: eng
  Problemas con Cron.daily (solucionado) César 5 2.484 04-10-2009 05:58 PM
Último mensaje: César

Salto de foro:


Usuario(s) navegando en este tema: 1 invitado(s)
Contáctanos | Portal de Noticias | Volver arriba | Volver al contenido | Archivo (Modo simple) | Sindicación RSS